Camera image capture fail, Phantom 3 Standard

As you can see from the Sketchfab attachment, Drone Deploy and my camera were working this past Thursday. That’s when I recorded the data from my 2.7 K camera on P3S. Yesterday, Fri. and today,Sat. the camera fails to record. It works well in DJI GO app. I turn that app. off, boot up DD and fly the mission as normal but the camera does not activate, no pix are captured. The message I get after several seconds of flying is that there is a camera error and DD tells me via message on the mobile screen to “PRESS THE CAMERA BUTTON” which identifies via a picture as on the upper left side of the controller above the toggle switch. **There is no such button on the DJI Phantom 3 Standard controller. **

Any one else have this or a similar problem? Phantom 3 Standard, Samsung G5 phone, DJI GO app. is turned off. All other settings are the same as Thurs. as far as I know.


1 Like

You don’t have a button to trigger the shutter?

no, not on the controller. Yes on the DJI Go app. when it is operating.

See any photo of a DJI Phantom 3 Standard controller or go to the DJI YouTube vids on “how to” for DJI Phantom 3 S.


This same thing happened to me . I have a Phantom 4 Pro. Have you gotten any help from DD. I have been trying to chat with them but have not gotten any reply

1 Like

Hello guys. Have had the same problem. Did post this a few days ago and no one have replayed. @chasemgray please take our comments.
Today it was even worse. Went to field had 4 flights to do was not able to do any of them (P3P on android device J72016.

As you can see the small window for the pictures never showed up. The fly was not recorded as usual with the white line. No pictures taken. The mensage press to start taking pictures showed Up, did press it and only 1 picture was taken and the camera was not looking down. Once back home have unistalled the DD app and reinstalled it. Now it looks to run better on my cel, tomorow will check if the app is runing ok again. My problems have started like a week ago after an update. Carlos.

1 Like

I feel your pain. I also have jobs to do and can’t because of this problem . This is very frustrating.

1 Like

I have not , as yet, Sunday morning 5th of March, 2017, I have not heard back from DD on this camera problem. I am running short on available data this month for my mobile device contract so I will NOT uninstall the DD app. and then re-install it every day to determine if the app. has been fixed for camera problems. Will DD notify us, the users, and I’m a ‘free app.’ user at this point in time, will DD contact us when the error is fixed?

I will watch this forum to see if other people have discovered a solution for the app. error. No doubt, the code writers are working to solve this at DD. Anything I can say about it will be of no help to speed up the programmer’s work. Thanks for your attention to this problem, DD. When your 3D modeling app. works, it is great !

Bad news guys the app did not start to take pictures. Flow ok but not pictures taken, no view of the camera, not white line showing the done flight. I am flying P3P on Sansumg J7. Drone firmware updated a few days ago. DD installed last Night. Carlos

Sorry to hear some of you are having image capture issues. We are trying to reproduce the problem and look at our logs to see if we can determine what is happening on those flights.

1 Like

This will often happen to me when the start point of mission is too far away from take off point. Either rotate your flight angle so your start point is closest to where you are taking off from or move closer to the mapping area and take off from there. Have confirmed this with my own flights and have been using DD for over 12 months now? Had this happen as recently as yesterday- tried 2 flights from about 800m away from mapping area- it flew to map area and flew path but wouldn’t take photos. Brought drone back (P3P) and drove closer to mapping area and 3rd time it worked.
May not work for you but worth eliminating as a cause.

My flights were close that was not the problem. I tryed to see flight log but there was not fly log. Carlos.

FrankSchmidtAVCAM, I had the exact same thing happen to me on Tuesday March 7. I was planning on mapping my farm, so I set everything up, opened drone deploy, clicked on take off and everything was going fine. My Phantom 3 Standard started off towards the first waypoint, but it did not say image capture started like normal. The picture count remained at 0 on the first run so I hit the return to home button and landed it. I restarted my drone and the app and it did the exact same thing on the second try.

I am hoping to try to fly again today and see if it works now. If anyone knows what the problem is, please let us know


1 Like

Good luck , Droneman ! I have not tried DroneDeploy for the past few days, no reason to if no one else is having any luck with it. I expect it will take a firmware upgrade to correct the problem and I know DD is working to find out where the problem is and what caused it.

I don’t know how Drone Deploy does updates of the app. ; just waiting to hear from other users if they have any luck. The problem may be restricted to Android and not iOS at all or it may be only with the Phantom 3 Standard.

I’ll wait and see. I’ve got a lot of other projects on my plate now anyway.

I am having the same issue tried to fly one not even 15mins ago.

So HefleyCh, what drone are you flying? Is it a Phantom and if so, which one?
Are you using an Android (Samsung, other)? or iOS (Apple) ?

Have you flown previous successful missions? If so, for how long in distance and time, and did your camera take photos? How many?


I am having the same issue with Phantom 3 Advanced, Android, Samsung Tab S2. All programs and firmware are up to date. No photos are taken and DD reports “Drone not responding to capture command” when it should start taking photos.

Hello, actually this is was my first real deploy but I plan on a lot more when this gets fixed. As far as what I was using it is a phantom 3 standard and it did the same as every one’s went up and started fly asked me to hit the capture button witch is not on the standard edition. Just curious if any one has a ETA on this fix would like to try it. I am wanting to practice so I can start a small business with this and grow to something more. So for you guys that are using this for a business any tid bits would be amazing.

I have no updates on solution to the camera capture fail from DD as of the morning of March 9th. The system did work well for me, 3 times that I tried it and I have two 3D models up on Sketchfab , one of my house and one of a local motel which is for sale; this I did for a realtor friend who is the listing agent for the commercial property. Had it not been a windy day, I would have manually photographed more of the oblique angles with my Phantom of the motel buildings’ fronts and gotten a better model; these are early days for me using DD.

I think it ought to be a simple bug to fix although I 'm not a programmer. The system worked well for me when it was working and failed only , as far as I can tell when there was an update in the firmware. If the firmware does not automatically update and a user does NOT download the app. a second time after first installing the earlier version, then that user ought to be able to still use the DD system; I think. Mine failed when I downloaded the DD app. a second time and it was updated; that’s when the camera stopped working. My camera does work under the DJI Go app. DroneDeploy does seem to fly the mission as programmed but the camera activation fails. I cannot see that anyone using an iOS based mobile device is affected by this bug but (if you are, please post it here).

As to commercial use of DD; I think it has merit for real estate marketing. Several realtors have seen my 3D models and like the concept. Sharing the image is easy and I have embedded the model in my own property for sale web page just like a photo. This avoids YouTube because the DD/Sketchfab 3D model of a home or motel is not a video. It is interactive which is a key point of marketing anything; viewer engagement. It is novel at this point and easy to understand and works on mobile as well as desktop devices. A 3D model of a property gives the listing agent a competitive advantage in marketing over other realtors and should help the realtor using it get more listing customers; if he/she shows off the 3D product to them.

No additional apps are needed to view the images ; the buyer prospect can see it just like any other photo. Larger real estate (farm, ranch or commercial acreage) would benefit from the DD system also and I have a 16 acre commercial property bordered by two parallel highways which I was in the process of modelling when the DD app. failed and my camera stopped working. That property will show very well with a 3D model in ‘terrain’ view; I hope.
You can see I’m optimistic about the DD app. and am just waiting for the fix.

I am having the same issue with Phantom 3 Pro, Android,Glaxy Note 3. No photos are taken. I have 3 different job/maps to do and I can’t do nothing. All programs and firmware are up to date.

I have tried last sunday 5th and today 9th.

Lot of people with same problem.

What’s happening with DD?

Hola Carlos,

Gaudi de Granada. Te escribo en castellano porque he visto en tu perfil la foto con el logo de BBVA… Para qué más pistas.

Te escribo para preguntarte si has podido resolver el problema de la captura de imágenes. Me ha pasado lo mismo. No captura fotos. Sale la ventanita esta de capturar fotos manual pero no sé para qué, si siquiera se puede orientar la cámara a cenital. La captura automática, que es lo que necesitamos no funciona.

Me han salido un par de encargos y estoy quedando fatal.

Te agradecería me comentaras si has podido o sabido solucionarlo.

Muchas gracias.