Beta 1.4.2 Bugs and Feedback

Thanks for trying the DroneDeploy app for Inspire/P3 1.4.2

Please add feedback and bug reports as a reply to this topic.



First time I’ve been able to try DD in a couple months so if anything I mention is a known issue I’m sorry.

AC FW: 1.5.11
RC FW: 1.4.3
DD APP: 1.40
Alltitude: 250ft
Default Overlap Settings
Weather: Mostly Cloudy/Overcast w/ 15-20 mph winds.

Area: 52 acres

Preflight Checklist: As Expected. No Errors

Takeoff: As Expected.

Flight Path: Even in the high winds it did a good job holding its path only had a few issues on turns as this was cross wind. When I was flying with the wind it maintained a speed of 33mph and when I was flying against wind it ranged between 8-13 mph. It seemed to handle this mph difference ok when looking at projections/overlap.

RTH/Landing: Soon as flight hit final waypoint it displayed that 251 images were ready for upload and began flight to home point. On return the flight stopped and hovered approximately 100-150 ft away from homepoint. I waited about 30 seconds and it did nothing so I switched to take control and landed manually. At no point did DD app crash or give me an error. It continued to display location/altitude/speed while I landed manually.

Upload Images: On dashboard it didn’t show any information about flight images. I chose the select directory option and it proceeded to attempt to upload all image from my SD card. I canceled when it had uploaded the images i needed.

What a delight to see how smoothly everything worked in version 1.4.0.

Almost everything went quite smoothly. The only issues that came up:

  1. Numerous attempts at pre-flight checklist had a failed test photo / camera error. Eventually resolved by formatting the new micro SD card we were using.
  2. Zooming in still causes a black background map far too early. If at all possible, would be better to have a pixelated map than nothing at all when zooming in to set plan boundary.
  3. One thing that would add considerable comfort is at least a random image or two from the flight fed back through the app. It would sure build confidence level to know that the imagery was in focus & properly lit.

Otherwise, noticed several improvements & much better stability.


This morning, had repeated problems with camera check failing. Issue persisted despite good functionality in GO and reformatting SD card. So I thought I would uninstall all DD apps (1.4.0 and 1.3.3). When I went to Play Store, it had reverted to 1.3.3 and with that the camera test passes, but mission would not load.

Had hood to try large mission to test how much acreage one can do with four batteries, but can’t continue mission at this point. Any chance you can push APK via forum until Play Store puts new version back up?

Do you see the button to ignore the failing camera check? It should let you continue even though we have trouble with the check. I’m interested to see if users have success continuing even though the check fails.

I’ll see if we can push to the store since users have had success the past few days.

There is no button to continue despite the fail, just a Retry Checklist button.

Ok. I’ll take a look why you can’t skip it. 1.4.0 should be he primary play store version in a bit.

Two test flights on 1.4, FW 1.05 on Inspire and Samsung Galaxy Note 5. Flights went well, aircraft flew fast and agile, almost a little too aggressive for my liking but it seemed efficient.


1: Cant back out of app using the back key on Note 5. I have to use the “close all” function on my phone to get out of the application.

2: Initial map screen overlay was blank (white) until I zoomed in and out to create my mapping mission.

3: The mission back button on the mission screen would not recall any of my previous missions.

Suggestion: No distances are displayed, it’d be nice to know the distance the aircraft flew and to be able to recall some mission details. Currently all i can see is how long ago i flew the mission and a image of the area I flew.

Overall I was impressed with the flights and will upload the imagery tonight to see how they turned out.

Anyone have any experience flying with a camera operator? if the “auto camera” function is turned off, can you adjust the camera settings while on a mission?


At the moment I think a camera operator adjusting the settings would be the only way to do it after the mission has started. We don’t change anything after it has reached altitude.

Okay, that’s good to know. Thanks Chase.

Yep! Even with auto camera on you can override mid-mission. You can run DJI Go on second tablet to get the in flight mission data you want as well.

Hi Chase,

downloaded latest version and it gives me still fails at the “take test picture” but I get an option to ingore. However when I slect that option it just goes back to the pre flight check list, the error messafge at the bottom still remains, the RC "buzzes and it wont let you go any further. The red “airoplane” button will not respond to start the mission…so still not able to do anything

I noticed this bug earlier this week. We are releasing fixes today for this and a few other small bugs.


Great, thanks. We’ll have to try it out.


Did this get released…cant see anything new in the play store?

Play store is version 1.4.2. What are you seeing?

the same…ok when was that updated because i’m pretty sure that was the version I tried that gave me the error

Which error are you referring to?

where it fails on the “take test image” check…then It gives the option to “continue anyways” but the airplane icon to press to continue is red…not green
Im just uninstalling and re-installing now to see if that helps