Battery error, app says battery is zero

I already created 1-2 maps with Dronedeploy beta app on Samsung Note 2 (with my inspire 1) but last week i replaced my phone with LG G4. My last map was on beta 1.0.5 and didn’t have any problem. But today i installed 1.0.8 beta app to my new phone and realized that the app gives battery error, it says battery is zero. I tried with my other batteries but nothing changed. I’m also a beta user on pix4d and saw many people say pix4d gives battery zero error aswell. I see this error on pix4d app too. I’m on dji beta firmware. Can u please find a solution for this?


The DJI beta firmware has a problem with reporting the battery and it also seems to spin between waypoints. Make sure to report these to DJI.

Oh ok, i will do this. Thank you.

Btw i see that they released firmware 02.02.22 but that page is unaccessible now. Can u find that firmware so we can try it for battery problem?

I am having the same error, reporting battery level at 0% with fully charged batteries installed numerous times. The pre-flight checklist fails every time and cannot enable the launch. The app has crashed a couple of times. The phone (samsung galaxy S5) wants to open the DJI app also… should I? I have tried both ways and get the same result. Total fail so far.

Are you using the beta firmware from DJI? There have been a lot of reported issues with that.
If the app is crashing you probably have the pilot app open in the background somewhere.

I am using the latest update from DJI version 1.03.0. I have ensured the firmware is up to date and the DJI pilot app is NOT running in the background. It still gives me the battery at 0% warning and says to update the firmware.

Are you using a phantom or an inspire. The latest inspire firmware isn’t working well for people and incorrectly says on its release notes that it adds sdk support.
If you have a phantom then let me know and I’ll see if I have any other ideas.

I was using the Inspire. I will try it on the Phantom 3 Pro now and get back with you.

People when been downgrading to the firmware in our getting started guide for using the inspire or avoiding upgrading completely.

I have tried numerous times now with the Phantom 3 pro. I am usually stuck in the “Waiting for Drone Turn on drone and transmitter/start simulator” phase. It got past that one time and while going through it’s checklist, it said I was not in A mode, but I was. I tried F mode also. I have restarted the app and also my phone numerous times. I even tried turning thing on the remote, the aircraft and the app at different times. A total bust for me. Neither the Inspire 1 nor the Phantom 3 pro will work at this point with your beta app. Definitely needs some work.

Sorry you’re having trouble.

Which firmware are you using with the phantom 3 pro?

If this is the first time you are trying to use it it’s unfortunate because DJI has made it difficult with their changes in the firmware we can’t do much about. We’ve spoken with them about it and they are working on fixes.

DJI also does not give us a good way to detect firmware so the best we can do is make sure the methods we need actually function as expected.

I’d like to figure out what is the issue you’re having. We have hundreds of people flying now and after an initial firmware update nobody has had blocking issues. If you’d like to email I can try to help a bit more.

The message to switch to A or F mode not working is often caused by the incorrect firmware. We have even less in the SDK to check that the phantom 3 firmware is correct.

Don’t worry about your batteries it is a bug in the phone software. Im flying with a phantom 3 pro aswell with the same bug. This doesnt mean you cant fly with it. The indicator bar still works(you know the one with green, yellow and red bars).
To start your drone you just have to use the manual override and it will still start and fly as it should do.