Auto land - can not take manual control

Happy Holidays to all!!!

Current issue: Updated DD app to latest version in iOS (iPad Pro). Inspire 1 FW version, updated RC FW. At the conclusion of mapping flight, everything going as usual. As the Inspire descended, I switched from F mode to P mode to take manual control as the launch area was covered with dirt and sand and I wished to hand catch the Inspire to limit dirt and dust collection on and in the bird. At the point where I changed to P mode, the Inspire stopped for a quick moment and then continued downward. I added power, the Inspire slowed its decent but continued to descend. Attempted to raise the landing gear (still in P mode) but gear would not rise. (i raise the gear when I want to hand catch the Inspire which keeps the blades in a safer position for the hand catch). Toggled the mode switch from P to F 3 or 4 times, still no manual control. Was able to get only a little control to keep the Inspire from crashing into some tall weeds but still ended up on a dusty, dirty landing area with a hard thump. Checked the bird over very good, cleaned out the motors and interior autopilot installation area with a can of Nitrogen and prepared for the next flight. Found a larger, more open area, did my flight without issues until it was time to come back to the landing area. Same thing occurred upon this landing procedure however, since the landing area was larger, I was not in danger of crashing and the auto landing finished with another hard thump.

Chase, I know you guys are working on it but wanted to report the latest (from two days ago) issue of this kind. I did have something that did work to relieve the issue and wanted to pass that along to everyone with this problem and to you to see if DJI can assist with helping you find the issue.

I did a large map of 500+ acres a few days ago and found that if I use the return to home (lower right hand “house” icon) just prior to finishing a flight, I could always gain manual control by toggling the mode switch to GPS (manual) P mode. This large area required 7 separate flights as the DD app would not allow me to design a full map of the 500+ acres and then use the battery change option, so I broke up everything into 7 separate flights. On the final flight, I allowed the Inspire to finish the entire flight to allow the automatic procedure that ensues upon finishing a flight. At the point of switching to P mode to manually land, there was no manual control; the Inspire continued to come down for a landing. Switching from P to F several times did not help and the Inspire came down with another thud. Bird OK. But from here on out, I will be touching the “home” icon just prior to the flight being complete as it, so far, has allowed me to gain manual control upon landing.

Hope someone gets the chance to test this for themselves and it helps eliminate this similar issue for you until DJI can allow DD some insight as to what the F*** they have done to the latest FW updates that would keep DD from solving this issue.

It’s useful to know the return to home works. We can probably use that instead of the DJI provided “land at end of mission” option.


Not releasing the control of the aircraft to the pilot with the mode switch is a serious bug, not an inconvenience. Actually, I did not know that it was even possible for an sdk based app to do that.

I will not be using DD Capture for this reason alone. Big safety issue, IMHO.

Happy Holidays guys!

Edit: I see this is mentioned in other threads. I hope you get this sorted quickly. Thanks.

As you can see you are able to take control using the RTH button.


Wanted to update you on the issue I have had with trying to regain manual control at the end of a flight to land the bird myself. I purchased a Matrice 100 a month or so ago and love the ability to extend flight times. Great workhorse of a bird. However, even with the latest DD version (iOS) and latest FW on bird and remote, the same thing is happening on the Matrice that is still happening on the Inspire. The only way I have been able to find that will allow me to take manual control just before landing is to press the “Home” icon at the bottom right of the DD screen just prior to finishing a flight. If I let it finish the planned flight and return home then I have no manual control but if I use the HOME icon just prior to the flight finishing (just a few photos before the end), I can always regain manual control upon landing. Scratching my head on this one as I am sure you are as well.

I have the m100 and have no problems taking control of the a/c. I do it two ways if the uav is close I will just flip the switch and fly it in and land. The other is if it’s far off and battery hits 30% I press RTH on the controller and in it comes, I then flip the switch and take control once it is overhead.

I’ve spent the last 2 days doing my first 5 DD map flights over about 400 acres. I’ve noticed the no manual control issue as well. I did use the RTH button before the end on one of my missions, and was able to gain control for a manual landing, but another issue that I see with this is now my mission doesn’t actually complete. Kinda bugs my OCD in my dashboard :). I’m flying a P3P and using an iPad for flight.

Where I fly it’s a must to have manual control on landing. I’m doing flying over cornfields and most of them have gravel roads next to them. If I autoland I’m likely to end up in a roadside ditch or a bad place in the gravel. To insure I have a good place to land, I haul a 3’ x 4’ piece of plywood that I put out for a launch/landing pad.

I’ve noticed some other issues, but I’ll have to find the other topics to address those.

I have found that the best method is to simply flip the switch and bring it home manually. Don’t get me wrong…RTH is great but I cannot remember the last time I used it on purpose. Perhaps on low battery it took over but I do not make it a point to press the button since I do not like to leave it up to my software to bring back my equipment. I have also found RTH to be buggy at times and given the DJI forum posts lately, some pilots that lost their drones in the water and other areas are regretting the use of it as well. Flip the switch and land manually unless severe changes or conditions prevent it.

The problem that I have is unless you flip to manual before the mission is actually complete you can’t override the system. It should be able to come home and let it come down to a reasonable altitude then takeover for a manual landing. That’s exactly how Maps Made Easy allows for manual landing. I’m flying a P3P so I’m not sure if it’s because I’m on an older bird that things are falling off the support system, but it’s pretty sad/dangerous that the safety of the system is being compromised when landing.

Do you happen to know if you are in beginner mode when you start the mission?

Pretty sure I’m not in beginner mode, since that would limit the flight distance and I’ve run flights to over 3,000ft from me.

This is a MAJOR bug and I will no longer use the App, nor should anybody else if they have the problem. Yesterday I lost the aircraft for a few minutes because of the bug. I had flipped the switch to take control of the aircraft and DroneDeploy refused to let me take over. While wrangling with the App the aircraft overflew me and I lost sight of it because I was looking at the screen. The video preview became slow and began to flicker. I pressed Return To Home, and the DroneDeploy App said that the aircraft was returning home, but the aircraft sat still and the RTH button on the remote was not blinking. I tried to rotate the aircraft to look for some landmarks, but the video suddenly became too slow and was flickering too badly to point the aircraft effectively- at least it was hovering somewhere instead of descending and now rotating by my command. I’ve seen this kind of flickering before when the aircraft is busy communicating, so I assumed the App was stuck in a loop constantly telling the aircraft to return home.

In desperation I closed the App completely and opened DJI’s App. The DJI App performed perfectly without any video issues, I was able to find a landmark and fly home. It turned out the aircraft was only about 600’ away, but I had no idea where to look. Fortunately I was performing an agricultural map over an extremely rural area and the aircraft was 250’ up.

The pilot should always be able to take control of the aircraft, no excuses. Not being able to take control of the aircraft is dangerous and is in violation with FAA’s AC_107 (see paragraph 5.2.3). This bug needs to be fixed before the App is ever used by anyone. I have version DroneDeploy 2.0.24 on an iPad mini2 that is only used for the drone. The aircraft is a DJI Phantom 3 Advanced.

1 Like

I think we may be preaching to the choir on this issue, unfortunately. I’m right there with you on this being a dangerous situation. I’ve been lucky enough to only lose control and have it continue to land, but your situation is even worse. I’ve flown about 12 flights with DD and every one of them exhibited this issue. I too am not going to be using the flight side of this software going forward. If this turns out to be a lack of support for Phantom 3 models this is a drastic oversight. There are tons of P3’s out there that are used and make great entry level birds for the market that they keep talking about pushing in agriculture where the farmer get a 107 license and fly his own crops. No farmer that I know wants to deal with something unpredictable as not being able to takeover control. Autoland is a joke in rural areas where you are more than likely looking at a landing zone of a narrow country road and ditches on either side. Risk for damage is too great. I’m thinking about starting to hand catch, but that’s not something I’m really all that comfortable with.

I’ll get off my soapbox now. . . Thump thump.

In another thread somebody suggested flipping the Mode switch from F to P twice. This works! I was able to gain control of the aircraft during a Return To Home.

Flip the switch from F to P twice.

Yeah, I saw that too. I’m hoping to be able to fly tomorrow and I will give that a shot. The interesting thing about manual control is that on a return to home for a battery change flipping the switch from F to P once works just fine. I hope this is an effective solution on the P3P as well. If it is it should allow the mission to fully complete and hopefully address another issue that I have with false mission starts on subsequent missions.

Don’t try it!

I Just flew again. I flipped the switch twice and had control, but after a minute or so DD took over again. I flipped a third time and had control, but within a few feet of the ground DD took over yet again. This time DD descended into my travel case and the aircraft strut struck my travel case. The gyro righted the craft before a prop strike with the ground, and I wrangled control away from DD yet again so I could land safely.


I shouldn’t have to fight back and forth for control of the aircraft. Thankfully we all take precautions and don’t overfly people, but that travel case could have been a person.

I reiterate, this is a real problem. I often fly construction sites and you have to be very selective on where you land. I land better than any app regardless.

This should be fixed in the upcoming version.

Has the update with this fix been released yet?

Hi @bgee,

Yes, this issue has been fixed and released to the App Store.

1 Like