App won't recognize camera during preflight check


It wouldn’t recognize the camera on my P3Pro either. That was about 10 days ago.


Hi @Huskerfan,

Which camera do you have and can you verify if you have “Use 3rd Party Camera” toggled on in your Settings?



I’ve moved on to using my Inspire and it works. I might try the Phantom 3 Pro again and report back some time.


Sounds good, keep us updated.


just connected with my P4Pro that I just got today. It connected just fine.


Thanks for the update @Huskerfan. Happy to hear your P4P is working well!


Hello, any news about this issue? Last update was 26d ago.


Hi @chocksmith,

I just checked in with our engineers and there is nothing new to share at the moment. :confused: We’re still working with DJI on this issue, but I will be sure to update this thread as soon as I have news to share.

I’m sorry for the inconvenience and the time it is taking to resolve this issue.



Dear Christina,
I cannot do my job because of this bug.
I will have to rent another drone to do my work.
I have a Mavic Pro.
Can you say which drones are affected by this issue?

Thanks in advance for your assistance.


Hi @chocksmith,

At the moment it looks like it’s only affecting Mavic Pro models.



For everyone using the Mavic pro… I was able to get my pro up and running. I had to reinstall the DJI software to both my drone and it’s remote via the desktop assistant software. Once I did that everything worked as it should. Give it a try. Hopefully it will work for you to.


OK… so today I updated Mavic FW and also updated DD app (android)… Did a test mission… Ticked all the Preflight boxes… then completed the flight… EVERY image was out of focus…!!! BAck to square one… so frustrating!


Hi @wiremu,

I’m sorry to hear this. Before you updated your Mavic’s firmware and DroneDeploy app, were all the images out of focus or was it a certain percentage?

Keep me posted,


Hi all,

If you’re experiencing this issue, can you update to the latest DroneDeploy app in the Google Play Store or iTunes App Store and update to the latest DJI firmware for your Mavic?

If you still experience this issue after the updates, please post a response to this thread immediately.



Hi all,
I have the same issue with a matrice 100 + X3.



Solved : I forgot to approve Use 3rd Party Camera.
No the camera is not recording any photos (I’ll try to find why).


Hi @Damien_Brunon,

It looks like your setup is not officially supported, which is likely why you are experiencing issues. I suggest taking a look at our Supported Drones page to see what we support at this time.



Hi Christina,

I have updated both DD and DJI but still the same problem everybody is complaining about, camera check fail on DD app for Mavic Pro. We are in a remote area in Madagascar trying to survey a mining area. Very frustrating. I don’t want to but forced to use other apps to complete the survey. The best app for remote work I found so far is Drone Harmony. It gives me the latest google map to work on. Sadly DD uses a outdated Google map. DD is loosing valuable customers Christina. DD should start to take this issue very seriously. Not all customers bother to inform DD of their problems. They simply move on by using other apps.


Hi @MavicPilot,

Can you verify what DJI and DroneDeploy app versions you have installed? When we last tested our latest app version and DJI’s latest firmware version, we did not have this issue and others have reported this as resolved.

Can you also verify that this issue is consistent? Does it happen frequently in non-remote areas as well?



Summary : Installed DD and now Phantom 4 camera not functional/no camera detected.

I signed up for a trial on 1/4/18. Till date I have never had issues with my P4.

However the DD app failed to recognise camera and ever since then I have lost the camera functionality even using the DJI App. I’m not freaking out (just yet) but would love to have this resolved and not feel like DD has wrecked my DJI P4!!!

Gear :

Phantom 4
Phantom RC (Latest firmware0
iPad Air (ios 11.3 15E216)