Any one tried the new 3d mode?


I did, drone did a lovely orbit, but span round lol not looking to the centre of area like dji go point of interest!

Did I do something wrong, or just buggy beta?!

Got to go back tomorrow for a real point of interest orbit…
iPad air2


It is not a POI like the DJI app. It runs on a different algorithm to look inwards and down based on the perimeter and altitude of your flight plan. It is primarily for single building type of 3D obliques where you are close enough to the building or object. It is somewhat generic compared to the control you have with POI.


Hi Gary, thanks for the reply, but it didn’t do what you said it should have. It did fly around the perimeter nicely, a bit lower I believe and the camera was at a good oblique angle… however, it wasn’t looking inwards, it was rotating on its axis, so only some shots were facing inwards. I forgot about this and uploaded the photos to DD…The 2d map is good, but the 3d one, well the target area was modeled well, but it does have a lot of the surrounding, badly, included!! I will delete the shots that are not pointing inwards and resend the photos, but. I will also be going back to fly it again!
I didn’t want to use dji go’s Point of interest as the area wasn’t circular, but an L shape. May I could do that in litchi.


Hi @FromTheAir,

Oh no, I’m sorry to hear our 3D Mode didn’t go as expected! The behavior you are describing was a known bug in the last version of the app. We have since released a fix for it in the newest update V.2.65.0 on iOS. At your earliest convenience, can you please update your app and give 3D Mode another try? Please let us know if the problem persists and we’d be happy to dive deeper on this with you.

We hope you have a more successful experience with 3D Mode on your next flight! Let us know how it goes.



Hi Stephanie, thank you for your reply, I will update and try again!
Hope the weather is OK tomorrow!
Thanks again,


I used the new 3D feature yesterday. It shot photos towards the center of the area which was great. The issue I had is that my Phantom 4 Pro traveled the perimeter very slowly, like 3-5mph and shot photos about every 15-20 feet. The perimeter was about 2500 feet so it more then doubled the flight time and added an additional 200+/- photos to the job.


Hi Stephanie, I tried again today, at first it was working, but about half way though it started turning round, away from the centre on the mission area and spin. I had to come back home as the battery was running out. Landed and swapped batteries but it wouldn’t continue, it went through all the checks, but then sailed at the last one, the flight plan. I had to manually fly the last part of the perimeter


Hi @Brian_Richardson

Our 3D Mode feature is mostly intended to capture perimeter images of structures, such as buildings for example, or smaller flight plans to improve the overall 3D model quality. That being said, when mapping large areas the perimeter or 3D mode might not be the most useful tool as it could take way too many images, in your case, +200 images. I invite you to test this feature is a smaller flight plan to see how that works for you. If you are still experiencing drone speed issue, just let us know the name of the flight plan associated and we could further look into this.

I hope this information is helpful for you. Happy flying!


Hi @FromTheAir,

Thanks so much for providing this information and I’m sorry to hear about your flight experience. If possible, could you please let us know the name of the flight plan associated so we can take a look at your flight logs?

I look forward to hearing from you. Have a great day in the meantime :slight_smile:


Hi Andrea, thank you for your help and for asking to look at the flight logs, it was called “Copy of copy of Surrey Sawmills” the date says Jan 30 2018, third one from the top on my dashboard.

Just to clarify, I flew the mission grid/nadir photos, all went well, it was the “3d mode” that only worked for half way round the area. My battery needed changing to finish the 3d mode perimiter flight, but after I swapped batteries, it wouldn’t let me continue. It went through the check list but stopped on the last one, “Flight Plan”, it said it couldn’t load for some reason. I flew the rest of the perimeter manually via DJI Go. I managed to nearly fly the perimeter, but then dji Go froze on me, then crashed completely. Lucky I aways maintain line of sight and flew back manually, so no insurance claim needed this time!!
I hadn’t updated the P4Pro to the latest update as I had heard of issues with this one and the drone had been flying faultlessly up to then. I got home and have done the update, will go out to re-calibrate and test fly as soon as possible.

Thanks again, look forward to hearing your thoughts on the findings from the logs,

thanks again,


I flew a large site yesterday and the 3D mode only really captured the edges. It took just as long to take those oblique photos as it did to map the entire 150 acres. I wish it could go a little faster and have an adjustable gimbal angle. It just feels like a product for a small construction site and I understand that, just isn’t working great for me.


Hi @John_senior,

Thanks so much for providing this information. I’ll get back to you as soon as we have some feedback in regards this situation. Thanks so much for your patience and understanding.

Hi @dwindham,
We are happy to hear that you are testing our 3D Mode. As this is a relatively new feature, we are still working on making it more reliable to map larger areas. We appreciate your comments and suggestions and we hope you can use successfully the 3D Mode to complement your overhead mission soon.



Its definitely helpful on small sites, I have used it and had incredible results compared to normal.


Also, Andrea do you know if ArcGIS pro supports the 3D models in any way? I saw you were GIS support


Hi @FromTheAir,

Hope you are doing well. So our engineers took a look at the information available and they didn’t find any error or issue related to the 3D Mode itself. It seems that maybe the battery swap could cause the issue. When changing batteries, it is always a good practice to power cycling the drone and RC and relaunching the app. When relaunching the app, it’s important to close it out completely rather than just sending it to the background.
Please give it another try and let us know if rebooting everything during the battery swap helps to clear this issue :slight_smile:

Happy Flying!


Hi @dwindham,

Sure thing! As far as I know, ArcGIS Pro supports importing the LAS and XYZ file formats. The OBJ file is not yet supported. Also, as the OBJ file is generally not georeferenced, then that could cause some issues, but this is not a common file format to import into ArcGIS Desktop or Pro.

I hope this resolves your question :grinning: Happy mapping!



Hi Andrea,
Thanks for getting back to me, maybe that was the problem, I don’t think I shut everything down, I will try again,


I flew a 19 acre site yesterday, and used the 3D mode. The pictures it took were too close together, and the P4P flew far too slow compared to the nadir images. While the data is usable, some polish on the 3D flight mode would be helpful: faster flight speed, and higher interval (less frequent) on the images. It’s wasting too much battery flying so slow.


IMHO 3D mode could travel at twice the speed and lose no quality in the 3D model. From calculations, in an orbit it is capturing an image every 1-2 degrees. Anything more than 5 degrees is a waste of time to me. That being said my site would have gone from 300 orbital images to somewhere around 100.


Has anyone tried 3D mode lately? I tried the function back in February and was getting really slow flight speeds when the drone started to fly the perimeter. I am going to be capturing some 90ft wide, 2-4 acre corridors and would like to get some oblique imagery to improve the models.

Anyone had any luck with 3d mode recently?