Any fix for DD and Samsung Marshmallow?

Can’t get Drone Deploy to work on either my Mavic Pro or P3A now that I’ve upgraded to Marshmallow on Samsung S5. (I’ve tried removing DJI Go default applications to no avail). I assume there is a workaround, but haven’t successfully used any.

Marshmallow on the Samsung changed the way they connect to USB and it is almost random if you can connect now. Lollipop worked fine, but I went to iOS iPad after fighting with Marshmallow too many times on there.

Marshmallow works fine with the Sony Xperia Z3, but I have not heard anything good about the Samsung and Marshmallow, and it’s not the DJI side of things that’s erroring.
I don’t have an iPad mini, so I’ve found my old Xperia Z3 and are using that for the remote.

I’ve had lots of issues as well. But somehow it seems to work fine now (as long as I have a DJI camera attached; third party camera setup still doesn’t work). I did multiple tests with both my tablet on Marshmallow and my phone on Nougat. But, the sequence of your actions does have to correct. Maybe I’m just stating the obvious here, but for me, it only works if I:

  • switch on the controller first
  • then power on the drone
  • then connect the tablet or phone USB cable to the controller (after which DD starts automatically for me)

I noticed that any other sequence can cause issues, mainly being that DD can’t connect to the drone. Hope this helps!

I appreciate the replies! Thank you all!
Unfortunately for Samsung users, Marshmallow assigns default applications to USB connections that can’t be over ridden. I believe Drone Deploy is aware of this and is working on a fix. Once DJI Go (4) has been installed on a device, Drone Deploy will not have authorization to communicate with the drone. I have tried clearing defaults. removing all drone related apps and only installing Drone deploy. I haven’t tried resetting my phone or going back to lolipop (I’m not going to go that route anyway :frowning:
I now use another app which at least allows me to map a mission (Pix4D). Pix 4D I don’t find as user friendly as Drone deploy, but they’re on the professional end of mapping (duh) and have come out with an app add-on which allows Samsung Marshmallow users to map AND fly missions. Until DD can get around to such a work around, Pix4D will be my default app.

Hi @MarkO,

There is a way around the the Marshmallow USB issue. I have included an article which shows you how to work around the Marshmallow USB issue.
We are working hard to find a solution so you do not need to go through this work around. Given the way the Samsung has designed this workflow, it has been hard on our side.

1 Like

It can be overridden, just like @Nipul here explained… works for me, for both Marshmallow and Nougat. But you do have to maintain the correct sequence of steps, as I described :slight_smile: