Android App - Out of focus - no orbit


#1

After trying the new Android app today, sadly every photo is out of focus and unusable.

I saw you mention focus problems in the update notes, but how do we get around this? If I use manual camera settings from dji go, then DroneDeploy wont connect again. Also it took multiple attempts to get the waypoint upload to work.

And at the end of the mission the orbit function did not work, the drone just returned to the home point.


#2

Which drone and camera are you using? Phantom 4 Pro?


#3

Sorry yes Phantom 4 Pro


#4

This was mentioned in the release notes, it’s not always the case though. We are releasing an update with better focus on ios and android next.


#5

Yes as I said it was mentioned, but how can I overcome it? The app is unusable with this problem. Why IOS first after waiting so long for Android. Is there no workaround?


#6

Just pushed an update to the android store. This should be available in the next hour or two and it should fix this.


#7

I’m not sure if it matters to all apps, but one thing I run into is when I use manual camera settings in DJIGo4, even on previous flight to remember that I need to adjust camera settings before starting DD mission. If you leave it on manual when you shut down the drone on reboot it will not change the camera settings so when you get ready you will have the same camera settings as your last flight. Both DD and Pix4D behave this way for me.

I’m not sure what type of android you are using, but on my Samsungs I have to start in DJI to get camera set, then close DJI, go to applications and clear defaults (because Samsung thinks I clearly only ever want to do ONE thing when I connect…grrrr) and then unplug controller and re-plug it in so that it will ask what app I want to use and open DD. That is my workflow for starting a mission.


#8

Looking forward to iOS push next. Blurry and overexposed images with Mavic Pro on a commercial job were a big disappointment to us and the client.


#9

iOS push coming up next. Android is out now with focus fixes.


#10

Are you using a p4p? I want the exposure to be automatic, but the focus to be manual (unless drone deploy can autofocus itself properly)


#11

I’m using Mavic Pro. I haven’t tried hitting the focus button on controller while in DD app, but I can’t see why it wouldn’t work for manual focus.


#12

Does that mean we should turn on auto settings for the camera in the DD app and it will work?


#13

We released 2.0.32 on Android and it should fix most focus issues. We saw a few small issues still and 2.0.33 is coming tomorrow.


#14

Sadly still out of focus in every image using auto camera settings :frowning:


#15

I just flew an offline Android mission with my P4P and Nvidia Shield K1. The images look perfectly in focus. Uploading for map processing now.


#16

I think I’ll have to use manual focus until the issue is fixed


#17

@chasemgray Have you had any luck resolving focus issues on the X5 with the new releases? I appreciate your guy’s hard work in resolving issues, btw. Sounds like it’s no easy task.


#18

I processed my map and everything looked fine, so whatever the problem is it isn’t an issue with my drone/device combo. Later this week I’ll be trying the appended orbit for the first time and I’ll report back.


#19

OK, I had a very frustrating day yesterday trying to do offline mapping at a location that’s about 3 hours away.

At first the mission icons displayed with the edit icon (pencil) and I had to start, restart, unplug, replug several times to get a ready (airplane) icon. I finally started a mission which worked just fine except that the aircraft only took 5 shots, then the camera faced forward and finished the mission without snapping any more pictures. After that I couldn’t get a mission to fly and I kept getting the “cannot upload to a mobile device.” message. So, I didn’t get to test the end orbit because I wasn’t able to get another mission to run.

Fortunately I had a competitor’s app installed on my device and it worked flawlessly.

I really like so many things about DroneDeploy and it would be my first choice, but either its function is too obscure for my tiny brain to make it function or its very buggy.


#20

I had the same ‘out of focus’ problem. Newest DroneDeploy App installed on NVIDIA K1 Shield/Mavic Pro

Any solutions? Tried formatting the SD card, performing shamanistic rituals…Nothing helps.