Android 10 DD crashes immediately - RESOLVED

Haven’t used DD for a few years. Running Android 10 on a Google Pixel 2 XL with a Phantom 4 Pro. App crashes as soon as I try to launch it.

Since the phone and the drone are both on the supported list, perhaps DD is not supported on Android 10 yet. Can someone please confirm?

Good morning @NeilMcK. You are correct that DD does not work on Android 10. I have a Pixel 3XL and it has not worked ever since I went into the beta program. Most of the apps that fail are due to change in the Android location services, but we cannot be for sure that is what is causing this failure. I left the topic alone because I knew (and was warned) that many apps of this type would not work when I signed up, but if it is now being released through public channels then it is time to start looking at it.

@Kaitlin @Erika_Houseman

Thanks @MichaelL . I subsequently tried other apps like Litchi and it too crashes immediately when I try to open it. Even the DJI Go app crashes within the first minute of opening it, for example if I try to go into an Intelligent Flight Mode.

So I am going to load up an older device of mine and use it for all these instead until the app makers (or the DJI SDK?) catch up with Android 10.

I think that’s a smart move for now. Pretty much all of my drone apps quit working, but using the phone was a backup for me so I just keep my fingers crossed for my iPad’s safety. :slight_smile:

Just wanted to report an update that if you uninstall Android System Webview that location seeking apps like DroneDeploy and Litchi will start working again. If your phone is like my Google Pixel 3XL then you cannot uninstall it, but you can force stop and disable it.