All images failed to upload (Mavic)

After planning and running a flight with DD, all 119 of 119 photos failed to upload. Why? Am I being a newbie doing something wrong?

I planned a quick flight for the sole purpose of testing DD. I went to the site, opened DD on my iPhone, picked a relatively quick grid, connected, and up the Mavic went.

The flight itself seemed to go okay, and all photos ended up on the SD card.

When I returned to the computer and tried to upload the photos, the uploader cycled through all 119 shots but failed on all of them.

Looking at the photos, the exposure is a bit bright, though I can’t recall if I let DD set this or if I adjusted it up. Subsequent photos and tests with other apps right after this flight appeared to show normal exposure.

If it helps, I have not yet been successful uploading from this hardware to DD. A previous test also failed.

DD iOS: latest version
iOS: latest version
Mavic: updated to latest firmware yesterday (2/13)
Uploading browser: Chrome on Mac OS X (latest versions)
Sunny day, a few clouds. 5-10 kts wind.

Screen capture of error:

Photo dataset:

Thanks for your photos, that helps a lot. We are checking to see if we see the same issue on our side. If so, we’ll let you know.

Have you tried multiple browsers? We aren’t seeing this issue when uploading those photos.

Safari worked now, though I could have sworn it didn’t when I was trying the other day. I’ll have to do some more flights to confirm. Thanks.