Accessing Map Engine Beta

I was trying to make an ag map today, but I do not have access to the new beta app firmware needed to function.

We posted some links in the latest release post.

After getting all of the firmware squared away, I had issue’s with Camera Check Failing. That is when it would load. After that it would proceed past waiting for sufficient GPS satellites from the beginning. I have uninstalled everything a couple of times and it still leaves me hanging at the GPS satellite checkpoint. I spoke with Neema for a while yesterday out in the field. She advised that everything looked OK on your end. Any ideas?

Im sorry, it would NOT proceed past GPS check.

I’ve seen this several times while testing. For some reason I always need to restart my RC when I see this. Not sure if the drone is really in a weird state or if it is something with our app.

I had tried that a few times last night, but nothi ng worked. Also, when the beta firmware is installed I cannot connect the app to rc or drone. It just says disconnected.

If uninstall the beta software and install 1.4.0 again, I’m good to go.