3rd Party Camera Does not work

When using the latest version of drone deploy from 2 days ago (v3.2.0) I can no longer fly with my SlantRange camera. I verified that 3rd party camera is selected but the preflight check gets stuck on checking for the camera. In previous versions the camera check wasn’t done when “3rd party camera” was enabled. Please advise.


I’m having the same issue and could not find a way for tha to work. I’m using iOS version


I’m also using a Phantom 4 without gimbal from DJI using an IOS device, P4 does not take off, it’s a camera error.

1 Like

Hi…Did you get it sorted?

v3.5.0 for iOS doesn’t pass over the camera check but v3.5.0 for Android is ok!

@Igor_Buzato @trevman @thiago1983 @geebd214 Hello! We have recently rolled out a fix to correct this issue which was on our 3.3 release. I would be sure you are using the latest iOS version and also Android version. As far as mobile device, I would be sure you are using a device that we officially support. A list of the devices can be found here: https://support.dronedeploy.com/docs/supported-devices


1 Like

I don’t think so! You might have fixed v3.3 but wrecked on v3.5.0 where “USE 3RD PARTY CAMERA” is useless for non DJI camera users, as we are not able to pass through the “CAMERA” checklist prior to takeoff. This happens to iOS version only. I have tested an Android version (v3.5.0) and everything sounds ok! Could you fix it?

I can confirm. An Android 3.5.0 version works fine for me

I have been using iOS version recently, thinking about switching to an android 3.5.0, I have Phantom 4 for work. If I got it correctly, android version works better.

Now you have updated to v3.6.0 but on iOS version “3rd Party Camera” error remains the same. I am not able to go through the “CAMERA” checklist for nothing prior to takeoff. I’m using iPad 4 mini, device that you officially support. I´ve had to downgrade to v3.4.0 which works perfectly to me. Could you fix it out?

Yeah - same for me iPad Air - DD version 3.6.0

Use 3rd Party Camera is checked but the app hangs on the camera check before take off. Tried a dozen times.

iOS App is unusable for us now with the Red Edge.

Downloaded Android App on Samsung Galaxy Tab A and it won’t connect to the drone, even when app is assigned as default. Same again on Samsung S8.

Please advise.

1 Like

The latest iOS 4.2 update gives a "Drone Connected, but no GPS lock. Move drone or wait for GPS Lock” and will not allow autonomous flight plans with a 3rd party camera. Drone Deploy gives a message “Poor GPS - Tap for Manual Flight” and will not allow the Pre-flight checklist to be carried out. This occurs when no cameras are attached as well.

When this happens have you completely shut everything down and moved to a different location? Also, have you verified with DJI go that enough satellites are visible and the aircraft will actually go green?

Hi Michael. More than enough satellites according to DJI Go. I have tried numerous times with complete power down on all devices, aircraft and controller with the same result. I tested with an android device today using Drone Deploy 4.1 and that connects and allows the pre-flight planning to commence without issue, although this doesn’t have terrain awareness at present. Also the android version of Drone Deploy is quite unreliable and does fail to connect at times regardless of the payload.

1 Like

Good, looks like you got the basics out of the way. I know that development has not gotten to Android devices yet, but is odd that you can plan with it on the web interface. I wonder if it still uses the variable altitude or if it just defaults back to the value entered?

What drone and camera?

The problem is with the Inspire 1 and 2. I haven’t tested it on the M210 yet. I finally found a work around. I first attach a DJI camera and connect to Drone Deploy with 3rd Party Camera selected. Once I get the green light that all is OK, I switch off the aircraft, leaving the controller and the app on. Swap out the DJI camera for the Sentera and power the aircraft. As soon as there are enough satellites, I get the green light and can now commence with the pre-flight and everything goes through perfectly. I hope that this can be sorted out in the near future.


@Andrew_Fraser, is this being looked at?