3D Model loads vertical and center point if off

My 3D model has loaded and the ground level is turned vertical. I am unable to rotate throughout the model. Is there a way to define the horizontal plane and center point of the model? I am looking to purchase soon but want to make sure it will do what I’m looking for.


One theory that I came up with as to why my map is turned vertical. I captured images for building walls first and then flew the mission where the camera then pointed down. The first photos in my set were all taken with the camera looking straight ahead and then once I engaged the mission, the camera of course turns 90 degrees, looking straight down. Is it possible that the DD system starts with the first images and builds upon them and because they were of walls and not the ground, my completed 3D appears to be 90 degrees turned up?

Hi - This s a known issue sometimes with Sketchfab and not a fault in the processing or your model. You need to go into the 3D settings page for the model on Sketchfab and under the General tab you will see the Straighten Model X Y Z adjustments. Try these to start with and see if they will correct the orientation. The best option though is to check the box below the X Y Z adjusters which says Show Advanced Rotation - this brings up a circle with axes of adjustment on it in different colours. Zoom in and grab each of the axes in turn and push or pull them round the circle to adjust the model to the correct plane of view.

I’m not able to find the 3D settings page that you speak of. Would I have to upload my model to Sketchfab to see this? Currently when I view my model on Sketchfab, it appears as Drone Deploy is the owner. I have tried to upload but my export is too large from Drone Deploy.

Hi - yes you need an account on Sketchfab and may have to pay for an account depending on the file size of the model. The 3D settings show up after you have uploaded the model and before you publish it

I’m having exactly the same issue.

I uploaded a mixture of the original photos from the mission (taken looking straight down), and two oblique passes taken from the same height as the original, and from 20m lower.

Map loads vertically, in ‘Lit’ mode (instead of ‘Shadeless’), in SD instead of HD, and has that ghastly coloured background. It can’t be rotated.

Maps of the exact same location which I created while in Pro trial mode, load perfectly and have a dark background. You can orbit them as expected. This is definitely a bug. Is there something you can do to fix this?

My trial has expired and I don’t have the work yet to justify. One test I wanted to do was to run 2 missions. The first with the drone deploy app running first and then supplementing my own photos of vertical shots. The second of my own vertical shots first and then run the mission. I am curious if it starts with the first photo in the set and builds off of it or not. Mine that is messed up was done as described in my second example and it was off center and orientation was messed up.

Tim, does yours fix in my first or second example?

I’ve tried both approaches since my trial expired. Everything I mapped during the trial (no obliques) was perfect, and still is.
Everything I’ve mapped since the trial expired is tilted on the wrong axis. I uploaded the exact same images from one of my earlier maps (no obliques) and it came out wrong. I tried adding obliques - still wrong. I tried uploading the obliques first, then the standard images later - still wrong.

I don’t think it has anything to do with the oblique images. I think it is caused by one of two things:

  1. The way it processes data when you didn’t fly a mission, but rather just uploaded the images and named the map, or
  2. The way it processes data differently when you’re on the free (‘Explorer’) plan as opposed to the Pro plan.

I don’t want to splash out $100 or so just to find out - I’m using this as a test of their customer service as well, and they’ve already admitted on Twitter that it’s a bug which they’re trying to fix.

I see. I ran 4 different maps while on the trial and all but one came out alright and it was my second one. 3 and 4 were fine. 2 was the only one i took several controlled photos first. 3 and 4 had controlled photos after the mission flight so I assumed that was the cause.

I was not pleased with the response above that told me to go to sketchfab and fix it there (not sure if that was a Drone Deploy support response). I would have to pay for an account to handle the size of the model. I thought that was poor service and it didn’t sound good for the future when I might be a paying customer of the DD software but then have to pay again to “fix” what I’ve already paid for.

I didn’t get as much out of the trial as I would have liked due to weather and travel requirements. I wish I could get another month to test it out. I’d be much more prepared this go around.

They’ve fixed it! Not only that, but existing maps have been rectified as well.

Thanks DroneDeploy.

Is this fixed? As i am having the same issue with my maps. http://drdp.ly/eSs3Re

They did not fix mine. As you can see above, I was given directions on how to do it in Sketchfab but in order to do that I will have to pay for a Sketchfab account because the free level can’t handle the size of my model. This is horrible. Come on Drone Deploy! Why can’t you fix it?

As a quick follow up. I re-uploaded my photos last night without uploading the obliques that I took first and the model came out correct (less quality of some walls as expected). My theory from October 16th (above) may be correct in that I will always fly with Drone Deploy first and then manually take the obliques afterwards that way they are later in the set. I did this on an earlier model and it worked fine. So thats my conclusion, Drone Deploy flight first and then manual obliques second.

First upload with obliques first: http://drdp.ly/1GRV8Z
Second upload without obliques: http://drdp.ly/kJA3wB

Our apologies for not getting your models sorted out sooner. There was a period of time where we had a higher number of failures with Sketchfab, and have recently addressed the issue, as I think jse1982 saw with a second attempt. For older 3D models it is possible their orientation and other model settings were still incorrect. I have investigated your model raineysw and it appears correct at this time. Please don’t hesitate to reply or contact support if you have additional issues.

Conor Brady
DroneDeploy Support