3 Good Ones, all in the same mission

Hello Everybody,

  1. I have added to my S2 tablet a microSD card and, related or not, it was the first time I noticed a blue arrow on the bottom right corner, right above the airplane sign, from which I was able to look for a previously created desktop mission on the same area. The first problem is that this plan did not show up automatically when I opened the DD app, instead the DD showed the usual initial grid with the right satellite imagery behind it. I chose nevertheless the synced mission. The second problem was that the synced mission did not have any kind of satellite imagery behind it. I proceeded anyway. I got an error 235 along the way and it crashed the app… It is the first time I see the DD app crash… It should be nice to have also a human equivalent for machine error 235 in DD app.

  2. I always get the unable to take a test shot camera test in DD after a battery change. The workaround I use is to close the DD, close the RC, restart the RC and chose Litchi. Litchi starts recording a video by default, I stop it, close Litchi, close the RC, restart the RC and chose DD and it usually does the trick, i.e. the app does not get stuck in the test camera as it usually does after an accumulator change. I might have forgotten to stop recording, before closing Litchi this time, I am not sure. But the remarkable fact is that DD proceeded to the task and instead of producing photos, it FILMED the whole mission, camera faced down, starting exactly from the point it should have started taking pictures… DD could get improved by checking if the drone is not programmed to film before the flight and turning this feature off if active.

  3. I moved up a little bit and I tried a new mission. This time I programmed it at 100 m instead of 80 m as I was low on battery juice (all the accumulators I charged 100% on the 28 Dec 2015 were down 40 percent after two weeks on the 14th January 2016…something to pay attention, especially when outside is cold). DD app showed all the checks with green and then displayed “Starting Mission” and nothing happened, I was looking at a black screen with that message on and the drone did not budge, did not start engines, nothing, only the battery LEDs were blinking… I tried to cancel and the next screen I got was a black screen with “Cancelling Flight” and again nothing happened… I tried the same two more times, even calibrated the unit, to the same result. As my fruitless efforts were attracting unwanted attention, I packed up and left for another site, which was suitable for a 80 meters altitude survey, as that looked as the most probable cause of the mishap. I got there and got the same behavior but this time I wasn’t going to be deterred… I closed the RC and chose Pix4D instead. This app did report something strange, that the drone was not flying, kind of hilarious, as I could testify to the same behavior and their solution was to get airborne manually. I tried that and failed from within Pix4D, so I exited the app and got back to the classics, DJI Go. DJI Go had the courtesy of affixing an orange message telling me that the drone accumulators need to have at least 15 degrees Celsius before the drone was able to take off… Aha! So that was the ominous message when starting DJI Go about the last P3P firmware update, about running the drone in cold weather. The P3X_FW_V01.06.0040.bin is the first firmware that I know of to update the battery firmware. So the young drone won’t play unless some warming up is done to her batteries :wink: I got back in the car, turned the heating to max and kept the battery near the air vent until it felt warm. Outside we had a mere 2.5 degrees Celsius and the fact that I was using the P3P box with the accumulators inside as a take off/landing pad led to their gradual cooling, which explains why the first mission was - kind of - successful and the next ones failed. With the warmed up accumulator the P3P flew its entire mission and collected the photos I needed. The DD app should get some tests done before flight to address the error caused by the too low temperature of its current battery pack.

That’s all for today, pretty adventurous :slight_smile: I am looking forward for the new and improved DD app for Android :stuck_out_tongue:

I have had the same problem with the camera not responding.

I have an Samsung S2 with DJI and Drone Deploy up-to-date software and a DJI Inspire 1 with the second latest update for the camera and latest update for everything else (1.06). I went back down to see if the camera would work with an older version of firmware but that was not the problem.

I don’t know how you figured out that you needed to:

  1. Close the Drone Deploy
  2. Close the Remote Control (turn it off)
  3. Restart the Remote Control
    4 Choose Litchi which then starts recording video by default
  4. Stop video recording then close Litchi
  5. Turn off the Remote Control
  6. Restart the Remote Control and choose Drone Deploy

However, this does not work every time?

I will try to keep up with this topic as I have a lot of surface to photograph and process.

Dear Scott,

It does work every time if it is followed to the letter. I figured out this procedure out of desperation, actually… I was out in the field, 500 km away from home, in subzero temperatures, with an archaeologist having a look on his face like “Why are those people called engineers going to those universities that can’t teach them to solve “basic” problems?!” so I tried everything I could get my hands on already present on the S2 tablet. Litchi was there since I believed when I got it that would actually get the aerial surveying job done and only later on I found out about DD, which is really a great concept with some minor rough edges to trim.

Regarding the camera issue, it must have something to do with the creation of directories on the microSD camera in the drone. I encountered the problem when the microSD was empty, just formatted, but also when there are images from previous flights. If you look closer, under the DCIM directory there are multiple directories, called 100MEDIA, 101MEDIA, up to 105MEDIA in my particular case, and inside them the images names range from DJI_0001.JPG up to DJI_0999.JPG, so no more than 1,000 images per subdirectory. Maybe the DD Android app is not properly identifying and using the existing directory resources on the microSD media. Having such a directory structure requires a bit more programming than a simple DCIM\100MEDIA\ structure. Maybe DD does not have sufficient write rights or create directory rights in the Android environment. Maybe that is why DD has the 1,000 images limitation, I am just guessing. But programming wise, it should be a fairly simple one to figure out and fix.


I purchased the Litchi program (I was going to anyway) and your process worked!

Thank you,


1 Like