2 problems - drone went off course and data didn't upload


#1

Summary of Issue:
Drone went off course during a pattern on one flight, and wouldn’t return home on another. Data would not upload from iPhone when connected to internet.
Date Issue Began:
January 20
Drone Model:
Phantom 4 Pro
Mobile Device Model and OS version:
iPhone 7 plus ver 11.1.2

On Saturday, I planned a flight via my iPhone onsite, in which there was no internet connection. I began to fly the pattern, and in the first leg, the drone started to drift off course. Battery level at start was 68%. When I saw it go off course, I hit return to home, and it started the flight to home, but flew past me. I had to manually take control and land it. I may be confusing this part with another flight…but it seemed to be semi responsive to controls and I was afraid I woudn’t get it landed, but eventually it did. Battery was 47% at landing. Flight speed was 10 mph at 350’, as I was flying over timber. Changed batteries and flew another mission, which was also created offline due to no internet. This one did complete the pattern but did a loop halfway down the last leg. When it got to the end of the leg, it kept going instead of making the turn. Again, I had to manually land. Got home and tried to upload when I got an internet connection, and would not upload to the server.

On Sunday, I created two more flight plans from home with internet connection in the same area, and set to make available offline. I was able to fly the first flight ok, again 10 mph and 350’. I noticed that in one direction the speed fluctuated from 10 mph to 4 the entire length, perhaps flying into the wind (winds about 3 mph). On the other direction, it was always a smooth 10 mph. Landed, changed battery, and copied that flight to fly the same pattern but changed direction to 90 degrees from the first pattern. Seemed to fly a little better, but I don’t remember because that flight doesn’t show up on my iPhone or in the desktop application (third problem). I then went to the other site which was nearby to fly over another section of timber, on the other flight I planned from home. Started the flight and halfway through the first leg I hit return to home because a video opportunity occurred that I wanted to use that last battery on with the DJI Go app. It started the return to home, and about halfway, it stopped. I tried to take manual control and it would move a little then stop. Then it went to 400’ and stopped. I ended up switching to the DJI app to get it home. A similar incident happened on Christmas Eve where it went to the start location and stopped. When I hit return to home, it went to 400’ and I was eventually able to get it home. Don’t know if it matters, but all of these locations were areas with limited or no internet connectivity.

I have been unable so far to get the flight plans to upload from Sunday’s flights. The first and third flights kept showing uploading flight plan until I turned my iPhone off last night and then turned it back on, and it doesn’t show that any longer. When I open the flight plan on either one, it has the save button like it’s ready to fly again. The second flight, which was a copy of the first flight, doesn’t show up any longer. The second flight from Saturday shows up on my desktop, but not on my iPhone.

If anyone can help me with what’s going on, I would be very appreciative.


#2

Hello @SAE

Thank you for reaching out. It seems there are many issues happening here as far as your flight. Could you provide me with the name of the flights you were experiencing these issues. I can check your flight logs and see what I can find as far as those flights. My guess would be that since you are flying offline, your RTH point was miscalculated. We will not know for sure until we get more information.

Also right now we are experiencing some slight issues with our uploader and want to be sure you are not affected by it. You are more than welcome to upload your datasets directly to the dashboard by pressing the blue button with the + sign vs uploading to your flight plan. This is a workaround we have seen that works. Please let me know if you are still having issues and we can reach out and further assist.

Thank you!


#3

Yusuf,

The flights on Saturday may have been named Untitled. I don’t have them any longer. The first flight on Sunday was called Near house site, and the second one was a copy of Near house site. The third flight on Sunday, the one in which it stopped and I had to use the DJI app to return home was named Near Houseboat.


#4

Hello @SAE,

Thank you for reaching out. I went ahead and took a look at your flight logs from “Near Houseboat” and “Near House Site.” Unfortunately I was unable to recover the flight logs for the other flights. I can go ahead and take a look at them if you are able to retrieve them from your Drone. I can reach out personally to your email to retrieve those flight logs if you are able to access them.

For the flight, “Near Houseboat,” I was able to see that your drone was able to takeoff. Your drone then changed into ATTI mode for a split second then went into its normal course of waypoints. At 90 percent battery level, your drone entered RTH mode then changed into GPS ATTI. Your drone may have been ceasing to respond due to the mode being ATTI mode, which is a full manual mode.

For the flight “Near House Site” I can see your drone was flying normally. It was during its last leg it lost connection to the RC and switched to ATTI mode. After switching to ATTI mode it made an auto landing due to low battery life.

I believe your issues were a result of your drone being in ATTI mode. Flying in areas of low/no connectivity may also influence this. I would plan your maps offline and make sure you are correctly saving these maps so they can be flown offline later.

As far as uploading your flight, please try to upload your flight directly to the dashboard and be on Google Chrome or Firefox browsers.

Thanks!