DroneDeploy App Not Compatible


#1

I have an Android tablet with a quad core A33 processor running Android version 6.0.1. When I try to download the DroneDeploy App from the Play Store it tells me that, “Your device isn’t compatible with this version”. Any idea how to fix this?


#2

Trying to fly a DJI Phantom 3 Professional


#3

I’m not sure why it says your device is incompatible. Until we’re able to figure it out I think you should be able to use a chrome extension to download the APK from the play store. Then you can click the APK to install it on your phone.


#4

Hi. I have a new Android 7.0 tablet. I’ve just downloaded and installed your APK throught APK Pure (Google Play said the app wasn’t compatible with my device). After login nothing appeared on my dashboard. Please advise.


#5

Hi @Philip_Mountain,

Is your device listed on our Supported Devices (Mobile and Tablet) page? If it isn’t listed here, there is no guarantee that your device will or should work without issue with DroneDeploy.

Cheers,
Christina


#6

Hi Christina. It isn’t listed. It’s a Teclast T10


#7

Hi @Philip_Mountain,

As noted above, since it’s not listed we cannot guarantee that your device will work with DroneDeploy and we do not have any workarounds to provide at this time.

Cheers,
Christina


#8

Ok. DD works fine on my Android 7.0 Samsung Galaxy S7 but i would be happier if I could use DD on a larger screen